FreeBSD 7 and java networking

David Taylor davidt at
Thu Nov 8 10:11:11 PST 2007

On Wed, 07 Nov 2007, Nick Johnson wrote:

> On Wed, 7 Nov 2007, David Taylor wrote:
> > I've tried compiling java/jdk15 and java/jdk16 bootstrapping with
> > all three binary jdks (diablo 1.5, linux 1.5, linux 1.6).
> > 
> > They all give the same problem:
> > 
> > Running jbidwatcher or azureus results in a mass of messages
> > like the following, whenever network IO is attempted:
> > 
> > Invalid argument
> Did you try running it with ?

Thank you!

As it turns out, I'd just noticed the global "WITH_IPV6=yes"
that I'd put in /etc/make.conf, and started recompiling java
without IPv6 support shortly before you sent that message.
I had already tried (both native jdks) with IPV6 turned
off in the "make config" menu -- or so I thought -- but
my choice was overriden by that forgotten entry.

The IPv6-less jdk works perfectly, now all that remains
is to figure out why IPv6 support has stopped working...

I'm fairly sure it worked fine before I switched motherboards
and upgraded to 7-CURRENT (now stable, or beta, or whatever).

David Taylor 

More information about the freebsd-java mailing list