[SOLVED] vpopmail POP: "ERR aac, chiled crashed" after reboot, core dumped

Chris Shenton chris at shenton.org
Wed Sep 17 08:44:42 PDT 2003

Chris Shenton <chris at shenton.org> writes:

> The machine was recently rebooted and vpopmail's POP now crashes upon
> successful authentication (names changed for privacy, sorry):
>   chris at PECTOPAH<104> telnet foo.example.net pop3
>   +OK <32620.1063584541 at foo.example.net>
>   user chris at email.zz
>   +OK 
>   pass MyPass
>   -ERR aack, child crashed

I rebuilt the OS, rebuilt the kernel, rebuilt vpopmail (same version)
-- to no affect. I was able to get it working again with a relatively
minor fix.  I'm documenting it here in case it helps anyone else.

In /usr/local/vpopmail/etc/ there are files: open-smtp,
open-smtp.lock, and tcp.smtp.  I removed the lock file and renamed the
other two to get them out of the way:

-rw-r--r--  1 root      vchkpw    1874 Sep 17 08:11 open-smtp
-rw-r--r--  1 root      vchkpw  302746 Sep 13 10:00 open-smtp.HIDE
-rw-r--r--  1 root      vchkpw       0 Sep 17 07:55 open-smtp.lock
-rw-r--r--  1 vpopmail  vchkpw    4015 Sep 17 08:11 tcp.smtp.cdb
-rw-r--r--  1 vpopmail  vchkpw    2112 Sep 17 07:59 tcp.smtp.cdb.HIDE

I was then able to POP in sucessfully.

Is there some way I should have been able to detect this problem?
Perhaps cranking up a debug flag and examining logs?

I don't know the code enough to know which binaries use these, but it
looks like they all use open-smtp.  Any clues for future similar
problems would be appreciated.  If crash-related damage caused this,
is it something that's worked-around in modern versions of vpopmail?


More information about the freebsd-isp mailing list