HP DL360 G3 Hangs on Disk Removal

Paul Lutt paul.lutt at fluke.com
Mon Jan 26 15:14:47 PST 2004

This is a followup to my original posting:

After trying both FreeBSD 4.9 and FreeBSD 5.2 on my DL360 G3 with a Smart
Array 5i controller and having both hang on hot swapping a raid 1 disk, I
tried installing both Debian and Red Hat Enterprise Server 3 on the same
system.  Both Linux installs experienced the same problem.

I started researching firmware revisions on the Smart Array 5i card.  The
card I have has 2.56 firmware installed.  All my previous servers have an
older revision of this firmware.

I installed 2.38 firmware on the array controller.  I tried the disk
swapping with Red Hat and encountered no problems.  I then re-installed
FreeBSD 5.2 on the server and performed the same test.  I have hot swapped
a raid 1 disk three times now without any problems whatsoever.

I'm going to contact HP to see what they might know about this problem.
The 2.56 firmware was release in Nov., 2003, so it is pretty new.

Thanks to all for listening to my sad tale.

Paul Lutt
Fluke Corporation
paul.lutt at fluke.com

More information about the freebsd-hardware mailing list