"swiN: clock sio" process taking 75% CPU

Gareth McCaughan gmccaughan at synaptics-uk.com
Tue Jul 18 17:05:19 UTC 2006

On Tuesday 2006-07-18 16:54, Deomid Ryabkov wrote:
> Gareth McCaughan wrote:
> > About 6 minutes after booting (on three occasions, but I
> > don't guarantee this doesn't vary), a process (well, a
> > kernel interrupt thread, I guess) that appears in the
> > output of "ps" as "[swi4: clock sio]" begins to use
> > about 3/4 of the machine's CPU.
> I recall seeing similar behavior on a Sun V20z, running 5.x at the time.
> I have definitely seen a lot of interrupts and CPU usage on the sio interrupt
> corresponding to serial console. Needless to say there was no activity
> on the console itself.
> I think turning off serial console solved that for me.

Do you mean commenting out the entries in /etc/ttys related to
serial TTYs, or something else? (I've tried the former, and it
didn't help.)

In the spirit of grotesque voodoo chicken-waving, I also tried
taking the "sio" device out of my kernel entirely. The problem
remains unaltered.


More information about the freebsd-hackers mailing list