4.8 "Alternate system clock has died" error

Charles Sprickman spork at fasttrackmonkey.com
Sat Nov 19 03:05:47 GMT 2005


I tried this query on -stable, hoping someone here can help me further 
understand and troubleshoot this.


In short, top, ps report 0% CPU on all processes as of a few weeks ago. 
"systat -vmstat" hands out the "Alternate system clock has died" error.

Box is running 4.8-p24 and has been up 425 days.  Nothing out of the 
ordinary except for the above symptoms.  In searching the various 
lists/newsgroups, it seems that the other folks with this problem have 
fixed it in various ways:

-early 4.x users referenced a PR that was committed before 4.8
-some 5.3 users reported this with unknown resolution/cause
-sending init a HUP was suggested (tried it, no luck)
-setting kern.timecounter.method: 1 (tried it, no luck)
-one user seemed to actually have a dead timer

In the stable thread one person answered, and they were the sole example I 
could find of a true hardware failure.  The odds are in my favor that it's 
a software issue I think...  My hardware that I was given is probably a 
bit uncommon; it's an SMP Athlon box (Tyan S2462 THUNDER K7), probably not 
the most widely-tested platform.

The -stable poster had a warning that if the RTC is bad, the machine 
likely won't come back up if I boot it.  That has me very worried as this 
box is very important (mail server).

Can anyone help me determine if this is a hardware problem?  If it is, I 
really need to stretch the budget and dig up some new hardware to 
transplant everything into.

Dmesg is in the linked thread.  If there's any other info I can provide, 
let me know.



More information about the freebsd-hackers mailing list