Removal of kern_xxx() no-at variants.

Konstantin Belousov kostikbel at
Thu Nov 13 09:38:58 UTC 2014

On Wed, Nov 12, 2014 at 11:31:45PM +0100, Jilles Tjoelker wrote:
> On Wed, Nov 12, 2014 at 05:01:24PM -0330, Jonathan Anderson wrote:
> > A thought:
> > If we're only going to have one of {kern_open,kern_openat}, might it 
> > make sense to keep the shorter name rather than the longer one? 
> > kern_openat as a name seems meaningful to me only if we're trying to 
> > disambiguate it from an also-existent-but-different-meaning kern_open.
> The name kern_openat makes sense in that the functionality is like the
> openat() system call.

I like the proposal, but think that it is premature, unfortunately.
Issue is the MFC to stable branches, which still have old functions
used in code.  I do not mean merge of this change to stable, but
other merges which intersect with the at/no-at modifications.  Having
kern_open() as different functions in HEAD and stable is too confusing
without real value IMO.

Note that it is possible to partially MFC the commit into stable, leaving
the removal of the no-at variants out of the patch.

More information about the freebsd-fs mailing list