Removal of kern_xxx() no-at variants.

Jilles Tjoelker jilles at
Wed Nov 12 22:31:48 UTC 2014

On Wed, Nov 12, 2014 at 05:01:24PM -0330, Jonathan Anderson wrote:
> A thought:

> If we're only going to have one of {kern_open,kern_openat}, might it 
> make sense to keep the shorter name rather than the longer one? 
> kern_openat as a name seems meaningful to me only if we're trying to 
> disambiguate it from an also-existent-but-different-meaning kern_open.

The name kern_openat makes sense in that the functionality is like the
openat() system call.

Jilles Tjoelker

More information about the freebsd-fs mailing list