why no automount for one zfs?

Matt Churchyard matt.churchyard at userve.net
Tue Nov 4 10:36:03 UTC 2014

>Steven Hartland <killing at multiplay.co.uk> wrote:

>> On 04/11/2014 09:17, Zeus Panchenko wrote:
>> > Steven Hartland <killing at multiplay.co.uk> wrote:
>> >> Missing zfs_enable="YES" in /etc/rc.conf?
>> > no, it is on it's place (I run root-on-zfs)
>> >
>> Add it,

>the option *is* in /etc/rc.conf, otherwise I couldn't boot since I run root-on-zfs

Just to be clear, the root filesystem is mounted slightly earlier in the boot process, regardless of rc.conf settings. (Obviously the root filesystem has to be mounted before the system can read what you've got in /etc/rc.conf)

However, if you don't have zfs_enable="YES" in /etc/rc.conf, no *other* ZFS filesystems will be mounted. This is a very common problem that catches quite a few people out, which is why you were asked to confirm.

>> cat /etc/rc.conf
>---[ quotation start ]-------------------------------------------
>#-*- conf -*-
>---[ quotation end   ]-------------------------------------------

>>  it will fix you mounting issue.

>the problem exists only for this single fs, all other fs are automounted correctly

At the moment I'd look at the possibility of another ZFS dataset getting mounted over the top.


More information about the freebsd-fs mailing list