UFS2 and/or sparse file bug causing copy process to land in 'D'' state?

Peter Jeremy peterjeremy at optushome.com.au
Tue Feb 24 22:32:23 PST 2009

On 2009-Feb-24 00:42:36 -0800, Carl <k0802647 at telus.net> wrote:
> The same truncate sequence has now been tried on a second system which is 
> hardware- and OS-identical. The same hanging scenario occurs on it. That 
> should eliminate the possibility of a defective hard disk as the cause.

Reproducable problems are _much_ easier to fix.

> The same sequence has also now been tried on a laptop, both natively and in 
> a virtual machine on top of WinXP, although both were FreeBSD 7.1 rather 
> than 7.0. Neither have failed so far.

So it's possible that the bug you are hitting was fixed between 7.0
and 7.1.  Is it possible for you to upgrade to 7.1?

> create/change to a new window and issue the reboot. New SSH connections 
> don't work. Commands like ps and date still work, but commands like ls go 
> straight into a permanent 'D' state themselves. Bad scene for a remote 
> system :-(

This sounds like a filesystem deadlock-to-root.  If you do get to DDB,
try 'showalllocks' and 'showlockedvnods'.

> It's all the kernel debugging stuff I've no knowledge of.

At this stage, all I can suggest is that it's time for you to expand
your knowledge :-)

Peter Jeremy
-------------- next part --------------
A non-text attachment was scrubbed...
Name: not available
Type: application/pgp-signature
Size: 196 bytes
Desc: not available
Url : http://lists.freebsd.org/pipermail/freebsd-fs/attachments/20090225/62e53bcd/attachment.pgp

More information about the freebsd-fs mailing list