should bsdinstall work?

Nathan Whitehorn nwhitehorn at
Tue May 4 20:35:18 UTC 2021

Yes, it should work just fine; however, we don't provision the microsd 
images for the installer, especially for -CURRENT. The actual OS is 
fetched in plaintext to allow caching and the MANIFEST files are what 
provides authentication -- they provide the checksums of the files that 
get fetched so that they can be verified against corruption and 
tampering. For snapshots, the current version changes all the time and 
that doesn't work; it also means that network-install media have to be 
set up with those checksums in advance. Where are you trying to install 
to? Usually the assumption is that the microsd images *are* the 
installed system rather than a tool you use to install a system.

On 5/4/21 3:22 PM, tech-lists wrote:
> Hi,
> I've been trying to set up a boot-from-usb3 raspberry pi 4. I thought
> i'd be able to do this by booting into latest current snapshot image for
> arm64 rpi (written to microsd), and then running bsdinstall as root.
> I can select the auto-zfs option then select the usb3 disk as
> installation destination. The bsdinstall selects the sets and downloads
> them, but then get the error:
> "error while fetching file://usr/freebsd-dist/MANIFEST : No such file or
> directory"
> also tried via release/13 image, same error. Looks like it's downloading
> the files but then the installer can't see them, something like that.
> the downloaded files are there:
> root at generic:~ # ls -lah /mnt/usr/freebsd-dist/
> total 187454
> drwxr-xr-x  2 root  wheel     4B Apr  9 06:51 .
> drwxr-xr-x  6 root  wheel     6B Apr  9 06:50 ..
> -rw-r--r--  1 root  wheel   158M Apr  9 06:51 base.txz
> -rw-r--r--  1 root  wheel    25M Apr  9 06:51 kernel.txz
> root at generic:~ #
> worth submitting a PR? or is bsdinstall legacy and I need to use some
> other method. I've not tried releng/12.2 yet.
> thanks,

More information about the freebsd-current mailing list