should bsdinstall work?

tech-lists tech-lists at
Tue May 4 19:22:39 UTC 2021


I've been trying to set up a boot-from-usb3 raspberry pi 4. I thought
i'd be able to do this by booting into latest current snapshot image for
arm64 rpi (written to microsd), and then running bsdinstall as root.

I can select the auto-zfs option then select the usb3 disk as
installation destination. The bsdinstall selects the sets and downloads
them, but then get the error:

"error while fetching file://usr/freebsd-dist/MANIFEST : No such file or

also tried via release/13 image, same error. Looks like it's downloading
the files but then the installer can't see them, something like that.

the downloaded files are there:

root at generic:~ # ls -lah /mnt/usr/freebsd-dist/
total 187454
drwxr-xr-x  2 root  wheel     4B Apr  9 06:51 .
drwxr-xr-x  6 root  wheel     6B Apr  9 06:50 ..
-rw-r--r--  1 root  wheel   158M Apr  9 06:51 base.txz
-rw-r--r--  1 root  wheel    25M Apr  9 06:51 kernel.txz
root at generic:~ # 

worth submitting a PR? or is bsdinstall legacy and I need to use some
other method. I've not tried releng/12.2 yet.

-------------- next part --------------
A non-text attachment was scrubbed...
Name: signature.asc
Type: application/pgp-signature
Size: 833 bytes
Desc: not available
URL: <>

More information about the freebsd-current mailing list