gptzfsboot trouble

Ronald Klop ronald-lists at
Wed Feb 8 12:26:47 UTC 2017

On Tue, 07 Feb 2017 17:08:44 +0100, Thomas Sparrevohn  
<Thomas.Sparrevohn at> wrote:

> Hi all
> Last week I decided to upgrade my FreeBSD installation - it's been a  
> while
> (September 16 was last time). Unfortunately CURRENT does not boot and  
> cash
> in a weird way. Both 11-RELEASE and 12 CURRENT boot loader seems to  
> attempt
> to read blocks that exceeds the physical disk. Initially I through it  
> was a
> hard disk error - but after a "oh" experience I realised that the
> "gptzfsboot: error 4 lba 921592" is actually beyond the physical  
> boundaries
> of the disk (300GB disk). In order to rule out different options - I
> installed a vanilla 11-RELEASE on the 300G with a simple stripe - it also
> gives the error but does boot - the LBA of the error is slightly  
> different
> on 11 CURRENT and comes up with LBA 921600
> I have scanned all the disks for physical faults and there seems to be  
> none
> and I have tried doing a single disk installation on each disk - they  
> give
> the same error - Does anybody have any idea? Included Photos as  
> sometimes it
> get through to the actual boot menu but then crash in another place
> I have some images - but they are 2 bit for the mailing list ;-)

Can it be related to this issue?

Would be nice if you tell more about the system. CPU? dmesg?
The 11-RELEASE did that boot from the same disk? In the mentioned issue  
there is the case that gptzfsboot does recognize a secondary disk (can be  
configured as mirror), but not the first.

As you say UFS works, the bug might be in the gptzfsboot code, because  
that is not used for UFS.


More information about the freebsd-current mailing list