gptzfsboot trouble

Thomas Sparrevohn Thomas.Sparrevohn at
Tue Feb 7 16:08:51 UTC 2017

Hi all


Last week I decided to upgrade my FreeBSD installation - it's been a while
(September 16 was last time). Unfortunately CURRENT does not boot and cash
in a weird way. Both 11-RELEASE and 12 CURRENT boot loader seems to attempt
to read blocks that exceeds the physical disk. Initially I through it was a
hard disk error - but after a "oh" experience I realised that the
"gptzfsboot: error 4 lba 921592" is actually beyond the physical boundaries
of the disk (300GB disk). In order to rule out different options - I
installed a vanilla 11-RELEASE on the 300G with a simple stripe - it also
gives the error but does boot - the LBA of the error is slightly different
on 11 CURRENT and comes up with LBA 921600


I have scanned all the disks for physical faults and there seems to be none
and I have tried doing a single disk installation on each disk - they give
the same error - Does anybody have any idea? Included Photos as sometimes it
get through to the actual boot menu but then crash in another place


I have some images - but they are 2 bit for the mailing list ;-) 


More information about the freebsd-current mailing list