Somethign missing in my environment?

Willem Jan Withagen wjw at
Mon Aug 22 15:02:56 UTC 2016

On 22-8-2016 00:43, Ben Woods wrote:
> On Monday, 22 August 2016, Willem Jan Withagen <wjw at
> <mailto:wjw at>> wrote:
>     Tried an old trick:
>     Build on another system (10.3) and then mount
>             /usr/src
>             /usr/obj
>     on the system to install on.
>     But that generates things like:
>             ERROR-tried-to-rebuild-during-make-install
>     So I guess that doesn't work any longer.
>     --WjW
> That trick still works for me, but you have to make sure the build
> environment and the install environment are the same. Namely that
> /etc/make.conf and /etc/src.conf are the same on both machines, and that
> they have the same architecture... Otherwise it will try and rebuild the
> differences during the install process.

Yup, that's how I knew it should work.

ATM I seem to be able to run into just about all possible problems to
upgrade this box.
But now it is claiming it is:
whatever that may be.

I have found the definition, and it is to prevent building during
install on ReadOnly obj-dirs. But it does not really test for that, it
just blocks any builds.
But tinkering in the build system is asking for trouble, so I'm getting
closer and closer to reinstalling. Which is bad IMHO, since this it the
first time ever that I cannot escape for this type of catch-22.

Giving it a last retry building over NFS mounts.

Which sort of worked after I exclude some boot code that nagged me about
things growing to big. Which I attributed to "-g -O0".
But then I was able to complete buildword and buildkernel.

So sort of happy. Now I need to find out why the reboot did not work.
But that requires me next to the box.


More information about the freebsd-current mailing list