ZFS: i/o error - all block copies unavailable #2

Kazik CC dmilith at gmail.com
Thu Oct 23 09:35:17 UTC 2014

In old post about same issue on 8.x tree, from 2009, I saw the patch that fixed some integer overflows for large disk sizes/ datasets for raidz.. maybe it’s something similar here, but for huge stripes?

Also, if it might be “bootloader launching too fast, before BIOS actually see all the drives”… so, maybe there’s a way, to slow bootloader down in case of huge drive?

65TiB is pretty huge virtual drive.
Besides that, controller launches all 36 drives properly before boot process is launched.. The zpool is untouched, I scrubbed it without any issues.

I’m pretty new to fBSD codebase, where can I look into the code for answers?

> On 22 Oct 2014, at 17:38, Edward Tomasz Napierała <trasz at FreeBSD.org> wrote:
> On 1022T1633, Kazik Chujwielki wrote:
>> So, I tried with upgrading to 9.3, installing bootcode from 9.3, then I booted 10.0, installed boot code again.. nothing helps.
>> Still ends on http://s.verknowsys.com/1a4f147cbb215da9b16eb61a7e9de9ed26470338.png <http://s.verknowsys.com/1a4f147cbb215da9b16eb61a7e9de9ed26470338.png>
>> I also tried scrubbing my pool, from ZFS point of view everything is just "fine”. No data errors.. it’s machine with ECC RAM, so corruption shouldn’t take place..
> Does the scrubbing work under 10.0, the same kernel that fails to boot?
> How did you reinstall the bootcode?

More information about the freebsd-current mailing list