ZFS: i/o error - all block copies unavailable #2

Kazik Chujwielki dmilith at gmail.com
Wed Oct 22 15:46:55 UTC 2014

> On 22 Oct 2014, at 17:38, Edward Tomasz Napierała <trasz at FreeBSD.org> wrote:
> On 1022T1633, Kazik Chujwielki wrote:
>> So, I tried with upgrading to 9.3, installing bootcode from 9.3, then I booted 10.0, installed boot code again.. nothing helps.
>> Still ends on http://s.verknowsys.com/1a4f147cbb215da9b16eb61a7e9de9ed26470338.png <http://s.verknowsys.com/1a4f147cbb215da9b16eb61a7e9de9ed26470338.png>
>> I also tried scrubbing my pool, from ZFS point of view everything is just "fine”. No data errors.. it’s machine with ECC RAM, so corruption shouldn’t take place..
> Does the scrubbing work under 10.0, the same kernel that fails to boot?
> How did you reinstall the bootcode?

I did scrubbing on 9.2 kernel (before upgrade to 9.3)

Everything seems to be fine:

  scan: scrub repaired 0 in 25h3m with 0 errors on Wed Oct 22 15:54:55 2014

I installed bootcode with "standard" way:

gpart bootcode -b /boot/pmbr -p /boot/gptzfsboot -i 1 mfid0

I did it on 9.2, then on 9.3, then on 10.0.. results are the same.

Currently I’m booting from mfsbsd iso. After networking setup I’m doing:

zpool -R /mnt import zbackup
mount -t devfs none /mnt/dev
chroot /mnt

and my system works just fine, no issues with ZFS at all.

More information about the freebsd-current mailing list