printing text file with LPD - non-printable characters

Beeblebrox zaphod at
Sun Oct 5 19:03:05 UTC 2014

> I moved the thread by setting Reply-To: to the normal
> freebsd-question@ list;
I'm using the nabble interface, so if the move does not work.. (I've never tried with moved thread before).

> First of all check, what encoding has your text file, UTF-8 or ISO or
$ file print.txt >  UTF-8 Unicode text, with very long lines
> Then run the file through the filter
Thanks for that idea - helped narrow down the problem to enscript:
$ enscript mytext.txt -o filter.txt
[ 4 pages * 1 copy ] left in ens.txt
59 lines were wrapped
7 non-printable characters
Resulting file has same encoding errors as hard copy.

* I should also mention that I tried this from both Desktop and from tty* with same results.
* Will any environment settings affect this? The only relevant entry is: LANG=en_US.UTF-8


View this message in context:
Sent from the freebsd-current mailing list archive at

More information about the freebsd-current mailing list