Problems with zpool upgrade embedded_data, and rebooting

John-Mark Gurney jmg at
Fri Aug 8 23:23:18 UTC 2014

Daniel Peyrolon wrote this message on Sat, Aug 09, 2014 at 00:41 +0200:
> Hello everyone,
> I just would like to gratuitously rant about something that happened on my
> machine.
> Basically, I upgraded my zpool to use embedded_data, since it would be more
> efficient, and rebooted. (I installed the system with zfs using bsdinstall).
> It turned out that gptzfsboot wasn't able to load that filesystem, so I
> tried to get it working from a live system that I have on a USB drive.
> It didn't work on that particular live system, but, fortunately, someone
> could do me a favor and download the latest snapshot, and burn it to my USB
> drive.
> >From there, it was a matter of importing zroot, mounting it at /mnt, and
> taking a look at the code of bsdinstall, trying to find the actual command
> to update the bootloader.
> I could manage to find it, and hopefully, everything worked again. Thanks
> to those who helped me :)
> What would be the better way to avoid this happening in the future?

Didn't you get the following warning:
# zpool upgrade -a
This system is currently running ZFS pool version 28.

Successfully upgraded 'tank'

If you boot from pool 'tank', don't forget to update boot code.
Assuming you use GPT partitioning and da0 is your boot disk
the following command will do it:

    gpart bootcode -b /boot/pmbr -p /boot/gptzfsboot -i 1 da0

Or something similar?

If you didn't follow the warnings, how else can we help you?

  John-Mark Gurney				Voice: +1 415 225 5579

     "All that I will do, has been done, All that I have, has not."

More information about the freebsd-current mailing list