Memstick Images not working (mountroot prompt)

Miguel Clara miguelmclara at
Wed Jun 5 14:53:05 UTC 2013

Forgot to CC the list, sorry!

In the meantime I upgrade from 9.1 using the base and kernel tarballs,
I could boot and I have wireless supported!

I have my ssd encrypted and the hdd too, the hdd is encrypted with
passphrase + key, and this key is in a usb stick (a different one form
the other two already tried).

The USB stick is not working to, and I also tried a USB Western
Digital 500GB disk, no luck either!

So no usb support basically...

dmesg output after connecting the device:

xhci_do_comand: Command timeout!
usb_alloc_device: device init 2 failed (USB_ERR_TIMEOUT, ignored)
usbgen0.2: <Unknown> at usbus0 (disconnected)
usb_reattach_port: could not allocate new device

Also note that usbus0 is a 3.0 as dmesg shows after boot:
usbus0: waiting for BIOS to give up control
usbus0 on xhci0
usbus0: 5.0Gpbs Super Speed USB v 3.0

So I guess this is indeed a problem in the 10.0-current kernel, not
sure what it could be or what more can I do to debug though...

Please advice,


On Wed, Jun 5, 2013 at 4:54 AM,  <miguelmclara at> wrote:
> I have no such option. Its a very recent ultrabook.
> Enviado a partir do meu smartphone BlackBerry®
> -----Original Message-----
> From: Glen Barber <gjb at>
> Date: Tue, 4 Jun 2013 23:45:34
> To: Miguel Clara<miguelmclara at>
> Cc: <freebsd-current at>
> Subject: Re: Memstick Images not working (mountroot prompt)
> Hi,
> On Wed, Jun 05, 2013 at 04:33:19AM +0100, Miguel Clara wrote:
>> Hello,
>> I need to Install FreeBSD 10 on my laptop to have Wireless support for
>> my card (ath) however I tried all of the available memstick images at:
>> And none of them works... I've tried 2 different pen drivers, one of
>> those is a generic cheap one, and another is a "DKingston DT 100 G2"
>> When typing "?" in the mount root prompt I see my ssd and hdd are
>> listed, but not the memstick (which I assume it should be da0).
>> I had no problems with the 9.1 stable image using the same memstick!
> I have personally boot tested the memstick images, without problem.
> What is 'Legacy USB' set to in BIOS on your machine?
> Glen

More information about the freebsd-current mailing list