gpart failing with no such geom after gpt corruption

Bartosz Stec admin at
Thu Apr 1 20:02:54 UTC 2010

On 2010-04-01 19:34, Marcel Moolenaar wrote:
> On Apr 1, 2010, at 6:23 AM, Bartosz Stec wrote:
>> Unfortunately it wasn't so easy. First of all system booted, and as I expected kernel message shows GPT error on ad1. Zpool was degraded but alive and kicking. However, when I tried to execute any gpart command on ad1, it return:
>>    ad1: no such geom
> If the GPT is rejected, no GEOM is created in the kernel. It's the GEOM
> that gpart(8) talks to, so the error indicates that the GPT is not accepted
> after you changed the disk size. For all practical purposes ad1 doesn't have
> a partitioning.
> The only gpart command you can use is:
> 	gpart create -s gpt ad1
> This creates a new GPT on the disk, wiping out whatever was there...
It was a middle of night when I played with that, so I'm not remember 
clearly if I tried it simpliest way like above or not. Maybe not, and 
all noise I made was pointless and caused by my inexperience with gpart.
Probably I just expected output from "gpart show ad1" be more like "no 
valid partitioning scheme on device" or "error in GPT table, please 
recreate partition scheme" in place of mystic geom message ;)

Sorry for noise, thanks for a hint and happy easter everyone :)

Bartosz Stec

More information about the freebsd-current mailing list