[Fwd: Re: [snd_hda][AD1981HD] microphone doesn't work]

Andrey andrey.kosachenko at gmail.com
Tue May 19 20:01:12 UTC 2009

Alexander Motin wrote:
> This patch was merged to 7-stable 4 months ago, together with the rest 
> of driver changes. 7.2-PRERELEASE had snd_hda driver almost (or may be 
> even completely) identical to the CURRENT of that time. So I don't 
> understand the difference. To find any difference in driver operation, 
> try to compare verbose dmesg of the driver in working and not working 
> systems.
> By the way, are you sure that problem is in driver itself? Can't be 
> linuxulator, Skype, settings or whatever else problem? What are you 
> using to record sound? Have you tried to use something trivial like 
> rawrec and rawplay?
> What microphone are you using: external or internal? Have you tried 
> another one? Are you recording silence or some noise? What mixer 
> settings do you use?

Oh, sorry, I didn't mention type of microphone :(. It goes about
internal one I guess (or in terms of snd_hda 'Connection type=Fixed').
External ('Connection type=Jack') works fine.

Attepts to record using rawrec\rawplay, skype test call, audacity   etc.
produce only monotonous hissing.

Not sure if I understood you correctly regarding mixer settings. Well,
all channels are set to 100, i.e. smth. like:
mixer | egrep -i 'mixer' | awk ' { print $2; } ' | xargs -I % mixer % 100

Unfortunately, I have no 7.2 alongside. Will try to obtain verbose
output from it and compare against current.

> PS: Next time, please, put file somewhere. Inlining broke lines, making 
> difficult to read it.

Sure, will take into account.
Thanks a lot for reply!

Andrey Kosachenko

More information about the freebsd-current mailing list