rum(4) not working on 8-CURRENT

Sam Leffler sam at
Wed May 13 14:58:01 UTC 2009

Thomas Sparrevohn wrote:
> On Wednesday 13 May 2009 09:48:36 Hans Petter Selasky wrote:
>> On Wednesday 13 May 2009, Thomas Sparrevohn wrote:
>>> Hans Petter
>>> I don't see this one came through - but I am having real pains with rum(4)
>>> - the weird thing it that it seems to work with HTTP etc but not with fetch
>>> - no panics - it just drops all connections and routing information - It am
>>> still getting the "kernel: rum0: need multicast update callback" error but
>>> I cannot see that it has anything to do with the issue
>> In my experience it's not the driver that is flaky, but the firmware in the 
>> hardware. I've seen several times that if certain commands are intermixed, 
>> the firmware will completely stop responding.
>> Has the rum driver ever worked with USB2 and -current? Recently there has been 
>> several changes in the WLAN layer and some minor changes in if_rum.
>> --HPS
>> _______________________________________________
>> freebsd-current at mailing list
>> To unsubscribe, send any mail to "freebsd-current-unsubscribe at"
> The driver stopped when the USB2 changes was reverted some time ago - prior to that USB2
> worked fine e.g. when the dummy multicast was removed etc

All usb drivers are tested with any net80211 changes; at least in sta 
mode.  Complaints about missing mcast and/or promisc support are because 
the drivers are missing code that breaks functionality.  Silencing these 
printfs does nothing except bury problems so they are forgotten and 
never fixed.

If you have problems w/ a wireless driver there are facilities to help; 
e.g. man wlandebug.


More information about the freebsd-current mailing list