rum(4) not working on 8-CURRENT

Thomas Sparrevohn Thomas.Sparrevohn at
Wed May 13 10:07:27 UTC 2009

On Wednesday 13 May 2009 09:48:36 Hans Petter Selasky wrote:
> On Wednesday 13 May 2009, Thomas Sparrevohn wrote:
> > Hans Petter
> >
> > I don't see this one came through - but I am having real pains with rum(4)
> > - the weird thing it that it seems to work with HTTP etc but not with fetch
> > - no panics - it just drops all connections and routing information - It am
> > still getting the "kernel: rum0: need multicast update callback" error but
> > I cannot see that it has anything to do with the issue
> In my experience it's not the driver that is flaky, but the firmware in the 
> hardware. I've seen several times that if certain commands are intermixed, 
> the firmware will completely stop responding.
> Has the rum driver ever worked with USB2 and -current? Recently there has been 
> several changes in the WLAN layer and some minor changes in if_rum.
> --HPS
> _______________________________________________
> freebsd-current at mailing list
> To unsubscribe, send any mail to "freebsd-current-unsubscribe at"

The driver stopped when the USB2 changes was reverted some time ago - prior to that USB2
worked fine e.g. when the dummy multicast was removed etc 

More information about the freebsd-current mailing list