[not completely SOLVED] acroread8 does not print any more

Rainer Hurling rhurlin at gwdg.de
Mon May 4 20:06:02 UTC 2009

John, thank you for answering.

On 04.05.2009 16:55 (UTC+2), John Baldwin wrote:
> On Sunday 26 April 2009 1:56:01 pm Rainer Hurling wrote:
>> A few days ago I reported about problems when I try to print from 
>> acroread8. For all but one of my systems the problem is solved now, see 
>> below.
>> On one system I also totally cleaned up the linux emulator part and 
>> installed everything from the scratch. Now when I try to print I get the 
>> following message:
>> ---------------------------------------------------------------
>> Beim Drucken ist folgender Fehler aufgetreten...
>> '/libexec/ld-elf.so.1: /usr/local/lib/compat/libc.so.6: version
>> GLIBC_2.2.4 required by /usr/local/Adobe/Reader8/DEU/
>> Adobe/Reader8/Reader/intellinux/lib/libgcc_s.so.1 not
>> defined'
>> ---------------------------------------------------------------
>> libc.so.6 is from misc/compat6x. I am not able to detect any relevant 
>> differences between my systems.
> You need a Linux libc.so.6 in /compat/linux.  You need to install an RPM that 
> contains this into /compat/linux (probably called something 
> like 'compat-libc').  Probably it would be nice to have a port for this (or 
> include it in the linux base port) for acroread8 to depend on.  I think this 
> is a ports@ issue though.

On /compat/linux/lib I have 'libc-2.7.so' and a link 'libc.so.6 -> 

#pkg_info -W /compat/linux/lib/libc-2.7.so
/compat/linux/lib/libc-2.7.so was installed by package linux_base-f8-8_11

But there is another libc.so.6:

#pkg_info -W /usr/local/lib/compat/libc.so.6
/usr/local/lib/compat/libc.so.6 was installed by package 

I have the CURRENT systems with, as far as I can see, exact the same 
configuration. On all my other systems printing from acroread8 is ok. 
Because of that I opened this thread :-(

I have no idea where to look next,

More information about the freebsd-current mailing list