[not completely SOLVED] acroread8 does not print any more

John Baldwin jhb at freebsd.org
Mon May 4 19:22:24 UTC 2009

On Sunday 26 April 2009 1:56:01 pm Rainer Hurling wrote:
> A few days ago I reported about problems when I try to print from 
> acroread8. For all but one of my systems the problem is solved now, see 
> below.
> On one system I also totally cleaned up the linux emulator part and 
> installed everything from the scratch. Now when I try to print I get the 
> following message:
> ---------------------------------------------------------------
> Beim Drucken ist folgender Fehler aufgetreten...
> '/libexec/ld-elf.so.1: /usr/local/lib/compat/libc.so.6: version
> GLIBC_2.2.4 required by /usr/local/Adobe/Reader8/DEU/
> Adobe/Reader8/Reader/intellinux/lib/libgcc_s.so.1 not
> defined'
> ---------------------------------------------------------------
> libc.so.6 is from misc/compat6x. I am not able to detect any relevant 
> differences between my systems.

You need a Linux libc.so.6 in /compat/linux.  You need to install an RPM that 
contains this into /compat/linux (probably called something 
like 'compat-libc').  Probably it would be nice to have a port for this (or 
include it in the linux base port) for acroread8 to depend on.  I think this 
is a ports@ issue though.

John Baldwin

More information about the freebsd-current mailing list