Atheros Card not detected

Sam Leffler sam at
Tue Feb 17 19:34:08 PST 2009

ro ra wrote:
> Hela,
> Ive been trying to get my atheros card working for a week now on FreeBSD 7.1 Release, i have tried using ath_hal 9.20.3 and 10.5.6 to get my atheros card working..but still my atheros card is not detected by the atheros driver. i also tried using ndisgen and my atheros card was detected and was able to connect to the wifi ap, however, the connection is not stable. it keeps disconnecting..and it keeps displaying
> ndis0: no matching rate for: 600
> ive tried updating to Freebsd current and recompiled my kernel, however my atheros card is still not detected. 
> Here's the ouput of pciconf -vlc:
> none0 at pci0:2:0:0:	class=0x028000 card=0x10671a3b chip=0x002a168c rev=0x01 hdr=0x00
>     vendor     = 'Atheros Communications Inc.'
>     class      = network
>     cap 01[40] = powerspec 2  supports D0 D1 D3  current D0
>     cap 05[50] = MSI supports 1 message 
>     cap 10[60] = PCI-Express 1 legacy endpoint
>     cap 11[90] = MSI-X supports 1 message in map 0x10
> i really want to get my wifi card working...please help..^^
This is a 9280 card. There is no support yet on any branch. The good 
news is I just received one; now all I need is free time. No eta.


More information about the freebsd-current mailing list