SATA hangs kernel during boot on MacBook Pro 4,1

Andrey V. Elsukov bu7cher at
Thu Mar 13 12:40:06 PDT 2008

13.03.08, 17:38, "Florian Smeets" <flo at>:

> one of the first things i did after i got my new MBP was to create a 
> second partition and try to install FreeBSD, but so far i was unable to :-(
> I tried to boot 6.2-RELEASE, 7.0-RELEASE and the March 8-CURRENT 
> snapshot, it didn't matter whether i tried amd64 or i386. The hang was 
> always at the same place and there were no messages or whatsoever. After 
> the DVD drive is recognized the kernel just hangs...
> I tried to set all the hw.ata. knobs to 0, tried safe mode from the 
> loader, tried disabling acpi, apic, usb, firewire and so on, still no 
> luck...

I've got a FreeBSD machine with CURRENT and it worked well.
It was about 2 months old. So, I updated it two days ago and i
had problems after that. System began hang on kernel loading. 
I tried boot with disabled MSI/MSIX and I had interrupt storms..
So, after several times of kernel rebuilding (i removed all 
unneeded at this time drivers) it booted without hang. I disabled
several devices in BIOS too (USB, Audio, COM, LPT, ..).
So I think the problem isn't in ata driver. May be ACPI?

WBR, Andrey V. Elsukov

More information about the freebsd-current mailing list