SATA hangs kernel during boot on MacBook Pro 4,1

Florian Smeets flo at
Thu Mar 13 08:05:53 PDT 2008


one of the first things i did after i got my new MBP was to create a 
second partition and try to install FreeBSD, but so far i was unable to :-(

I tried to boot 6.2-RELEASE, 7.0-RELEASE and the March 8-CURRENT 
snapshot, it didn't matter whether i tried amd64 or i386. The hang was 
always at the same place and there were no messages or whatsoever. After 
the DVD drive is recognized the kernel just hangs...

I tried to set all the hw.ata. knobs to 0, tried safe mode from the 
loader, tried disabling acpi, apic, usb, firewire and so on, still no 

I took a photo from a verbose boot with the 8-CURRENT snapshot in case 
it matters, it is available here:

FWIW Linux recognizes the controller and the disk as follows:

00:1f.1 IDE interface: Intel Corporation 82801HBM/HEM (ICH8M/ICH8M-E) 
IDE Controller (rev 03) (prog-if 8f [Master SecP SecO PriP PriO])
00:1f.2 IDE interface: Intel Corporation 82801HBM/HEM (ICH8M/ICH8M-E) 
SATA IDE Controller (rev 03) (prog-if 8f [Master SecP SecO PriP PriO])

lspci -vvv is available here:

ata3.00: ATA-8: Hitachi HTS542525K9SA00, BBFAC3GP, max UDMA/133
ata3.00: 488397168 sectors, multi 16: LBA48 NCQ (depth 0/32)
ata3.00: configured for UDMA/133

Is there anything else i can do? Any hints would be appreciated.


More information about the freebsd-current mailing list