device uart - does it work for anybody with PCMCI card?

Vladimir Grebenschikov vova at sw.ru
Fri Jan 18 14:51:16 PST 2008


On Tue, 2008-01-01 at 15:58 +0000, Bruce M. Simpson wrote:
> Vladimir Grebenschikov wrote:
> > Hi ppl
> >
> > Can anybody confirm that device uart just works for some PCMCI card ? 
> >
> > I've tried with two different cards (both are different pccard celluar
> > modems) and gets exactly same result.
> >
> > Device is detected, port can be open with any valid speed, but no any
> > communication, or probably, no any replays from modem.
> >   
> I see the same issue with "device uart" using a US Robotics Speedster 
> 28800 PCMCIA with 6.2-RELEASE. uart attaches, but I see the same 
> symptoms as you.
> 
> Rebuilding the kernel with sio, puc, and pccard statically compiled 
> results in the PCMCIA modem being detected as per onboard serial ports 
> would be (this Thinkpad T43 only has an IR port), and the modem works OK.

Ehhh, tried that way, yes, it was detected as sio4 device now, but still
no any response:

sio4: <Ubiquam UM-300> at port 0x400-0x408 irq 16 function 1 config 63
on pccard0
sio4: type 16550A
sio4: [FILTER]


> cheers
> BMS
-- 
Vladimir B. Grebenschikov
SWsoft Inc. vova at swsoft.com


More information about the freebsd-current mailing list