if_iwi, boot firmware

Armin Pirkovitsch a.pirko at inode.at
Fri Aug 29 09:52:19 UTC 2008

I guess I missed that part - works now, thx!

Lothar Braun wrote:
> Armin Pirkovitsch wrote:
>> Since my update from 7.0 STABLE to 8.0 CURRENT yesterday my wifi device
>> won't work any more. Loading the if_iwi and iwi_bss module works fine
>> and iwi0 is found - however as soon as I start wpa_supplicant I receive
>> the following error:
>> iwi0: timeout waiting for (null) firmware initialization to complete
>> iwi0: could not load boot firmware (null)
>> The configuration as it is worked fine in 7.0 and I haven't found
>> anythung in UPDATING which would indicate that I have to change
>> something.
> 20080420:
>         The 802.11 wireless support was redone to enable multi-bss
>         operation on devices that are capable.  The underlying device
>         is no longer used directly but instead wlanX devices are
>         cloned with ifconfig.  This requires changes to rc.conf files.
>         For example, change:
>                 ifconfig_ath0="WPA DHCP"
>         to
>                 wlans_ath0=wlan0
>                 ifconfig_wlan0="WPA DHCP"
>         see rc.conf(5) for more details.  In addition, mergemaster of
>         /etc/rc.d is highly recommended.  Simultaneous update of userland
>         and kernel wouldn't hurt either.
>         As part of the multi-bss changes the wlan_scan_ap and wlan_scan_sta
>         modules were merged into the base wlan module.  All references
>         to these modules (e.g. in kernel config files) must be removed.

Armin Pirkovitsch
a.pirko at inode.at

More information about the freebsd-current mailing list