if_iwi, boot firmware

Armin Pirkovitsch a.pirko at inode.at
Fri Aug 29 08:24:49 UTC 2008

Since my update from 7.0 STABLE to 8.0 CURRENT yesterday my wifi device
won't work any more. Loading the if_iwi and iwi_bss module works fine
and iwi0 is found - however as soon as I start wpa_supplicant I receive
the following error:

iwi0: timeout waiting for (null) firmware initialization to complete
iwi0: could not load boot firmware (null)

The configuration as it is worked fine in 7.0 and I haven't found
anythung in UPDATING which would indicate that I have to change something.

I even tried to enable the debugging mode of if_iwi - however it only
told me, that the problem occurs during LOADING state - which is obvious
I guess.

This is the wifi device I use:
iwi0 at pci0:1:3:0:        class=0x028000 card=0x27028086 chip=0x42208086
rev=0x05 hdr=0x00
    vendor     = 'Intel Corporation'
    device     = 'MPCI3B  driverIntel PRO/Wireless 2200BG'
    class      = network

Is there anything I can do to figure out / solve the problem?

Armin Pirkovitsch
a.pirko at inode.at

More information about the freebsd-current mailing list