Crash after trying powerd on FreeBSD 7.0BETA-2

Arno J. Klaassen arno at
Tue Nov 20 16:51:34 PST 2007

Kris Kennaway <kris at> writes:

> Arno J. Klaassen wrote:
> > Gregory Wright <gwright at> writes:
> >
> >> Hi,
> >>
> >> I tried enabling powerd on FreeBSd 7.0BETA-2 by adding
> >>
> >> powerd_enable="YES"
> >>
> >> to /etc/rc.conf.  The mobo is a Tyan 2882-D with a single Opteron
> >> 270 HE processor (dual core), 2 GB RAM.  AMD powernow was
> >> enabled in the BIOS.
> > I never succeeded in using cpufreq on any 288x MB. If freezes
> > box even with latest bios.
> Have you tried disabling acpi_throttle?

yes; but quite a long time ago; didn't make a difference

those boards go rather low in their minimal frequency (about
200-300Mhz if not even lower) and in at least 8 steps; acpi_ppc, which
works for me, seems to take into account only the four most powerfull
states (about 1Ghz being minimal then)

might be a "piste"


PS, while here, and totaly unrelated, rev (MFC "un-neede
singl-threading code") of kern_fork.c to releng_6, seems to break
things for me in a 4-way SMP (twice dual-core) amd64_releng6 box when
forking procs in java. I'll triple-check before once again sending a
bogus problem email but I got plenty of strange things when upgrading
a production box to recent releng_6 (for sake of testing ata-promise
TX4 patch), which disappeared after reverting to fyi

More information about the freebsd-current mailing list