Any successful installs on a Broadcom HT1000 chipset?

Travis Mikalson bofh at
Thu Nov 15 18:06:53 PST 2007

John Baldwin wrote:
>>> There is definitely a problem. The Tyan S3950G2NR (HT1000) on-board 
>>> SATA controller corrupts my data horribly and so does a Marvell 
>>> 88SX6081 8-port SATA300 controller plugged into the PCI-X slot.
>>> I have had to buy a couple cheap 4-port SiI3114 PCI cards for now to 
>>> be able to use this system with RELENG_7 and ZFS.
>>> Jeff Roberson wrote:
>>>> I have reports from a user that his install ends up corrupted.  I 
>>>> wanted to find out if it was a general problem with this chipset.
>>>> Thanks,
>>>> Jeff
>> I have several of these machines and i have tried installing Freebsd 6 - 
>> Freebsd 7 beta2 . The general breakdown is as follows. On freebsd 6 PATA 
>> mode works, SATA mode is broken. On freebsd 7 both PATA and SATA mode is 
>> broken. You can not even do a fresh install of 7 beta2. (I have only 
>> been able to use these machines disklessly)
> You can try this patch for HT1000, but it only affects having the chip in
> compat mode I think.
> Index: ata-chipset.c
> ===================================================================
> RCS file: /host/cvs/usr/cvs/src/sys/dev/ata/ata-chipset.c,v
> retrieving revision 1.203
> diff -u -r1.203 ata-chipset.c
> --- ata-chipset.c       26 Oct 2007 09:01:06 -0000      1.203
> +++ ata-chipset.c       15 Nov 2007 13:53:45 -0000
> @@ -4038,7 +4038,7 @@
>       { ATA_CSB6,      0x00, SWKS100, 0, ATA_UDMA5, "CSB6" },
>       { ATA_CSB6_1,    0x00, SWKS66,  0, ATA_UDMA4, "CSB6" },
>       { ATA_HT1000,    0x00, SWKS100, 0, ATA_UDMA5, "HT1000" },
> -     { ATA_HT1000_S1, 0x00, SWKS100, 4, ATA_SA150, "HT1000" },
> +     { ATA_HT1000_S1, 0x00, SWKSMIO, 4, ATA_SA150, "HT1000" },
>       { ATA_HT1000_S2, 0x00, SWKSMIO, 4, ATA_SA150, "HT1000" },
>       { ATA_K2,        0x00, SWKSMIO, 4, ATA_SA150, "K2" },
>       { ATA_FRODO4,    0x00, SWKSMIO, 4, ATA_SA150, "Frodo4" },

Though I'm having the same nasty data corruption problem with a Marvell 
PCI-X 88SX6081 8-port SATA300 controller, for the purposes of this 
discussion I'm only concentrating on the ServerWorks HT1000 SATA controller.

Thanks for the attempt, but it had no effect on the problem. I tried it 
in S-ATA and P-ATA modes (AKA SATA legacy mode on/off) and the problem 
is slightly less severe in P-ATA mode but still pretty bad. I even got 
ZFS to panic on an I/O error!

Even during the little bit of testing I was doing I could see the 
performance of the HT1000 on-board SATA controller (even in P-ATA/legacy 
mode) compared to the SiI3114 32-bit PCI controller is nothing short of 
amazing, it's too bad I can't use the fast one right now.

Here are things I've tried and have failed to work reliably with my Tyan 
Tomcat H1000S (S3950) ServerWorks HT1000 chipset motherboard's SATA 
controller for RELENG_7:

* Motherboard BIOS update (to 1.04b) which also updated the HT1000 SATA 
controller's option ROM.
* SATA controller in "legacy" (P-ATA) mode
* SATA controller in "legacy" and "non-legacy" mode with and without the 
above patch
* hw.ata.ata_dma="0"

Someone recently also brought up the theory that it might be a general 
PCI-X issue. I don't know, maybe a SATA+PCI-X issue or something. My 
on-board PCI-X "em" NICs work perfectly. I'm out of my depth to be 
saying much more than it's broken and what I've attempted.

TerraNovaNet Internet Services - Key Largo, FL
Voice: (305)453-4011 x101   Fax: (305)451-5991
Life's not fair, but the root password helps.

More information about the freebsd-current mailing list