ZFS from FreeBSD -> Indiana -> FreeBSD - some problem

Adam McDougall mcdouga9 at egr.msu.edu
Thu Nov 15 07:11:47 PST 2007


On Thu, Nov 15, 2007 at 09:25:56AM +0100, Pawel Jakub Dawidek wrote:

  On Wed, Nov 14, 2007 at 08:52:17PM -0500, Adam McDougall wrote:
  > For what its worth, I ran across a similar issue.  I moved a scsi card 
  > in my server which caused da2 and da3 (each with a separate zfs pool 
  > with no redundancy) become swapped, which I did not predict.  ZFS was 
  > completely confused by this, and rather than swap cables and reboot, I 
  > decided to try the export and import.  Worked fine.  I was a little 
  > dissapointed and surprised that I had to take action, but more surprised 
  > that such a simple fix was possible (yet predicted) when the error 
  > message on sun's website basically indicated 'you are totally screwed, 
  > game over, data lost'.  I wasn't in a situation were I would have lost 
  > any valuable data.  Maybe it was terminally confused because both 
  > devices it wanted were in use by the other 'failed' pool.
  
  In my perforce branch, this is already improved. FreeBSD will detect
  disk name changes, etc. It already does, but only with ATA disks.
  
  -- 
  Pawel Jakub Dawidek                       http://www.wheel.pl

Ah, so that probably explains why everything worked out fine when
I jumbled up 3 sata drives with a raidz zpool in another computer :)
I didn't keep them in order because I figured I could export and 
import if I needed to, but I was pleased I didn't have to.  Thanks.



More information about the freebsd-current mailing list