panic in 8-CURRENT / BGE hang

Coleman Kane cokane at
Thu Nov 8 06:35:48 PST 2007

Coleman Kane wrote:
> Cristi Magherusan wrote:
>> On Wed, 2007-11-07 at 10:30 -0500, Coleman Kane wrote:
>>>>  Hello,
>>>> I've tried again the latest version of if_bge.c on my HP 6710b
>>>> laptop with no results, even after setting hw.bge.allow_asf="0".
>>>> I've also tried with the debugger and it seems to panic when
>>>> calling free() in device_probe_child.c (IIRC). Then I #define'd
>>>> BUS_PROBE and the freeze occurs after displaying something like
>>>> "devclass_alloc_unit: now: unit 0 in devclass bge".
>>>> The 7 Beta 1.5 install CD hangs also when loading the driver.
>>>> I have a coredump made from whithin the debugger with the exact
>>>> place where the faulty free() occurs, so I can provide more exact
>>>> info if someone is interested. I just hope this is not a
>>>> heisen-bug.
>>>> Best regards, Cristi
>>> I have a 6715b that is experiencing the same exact problem. I made a
>>> release from 8-CURRENT as of last night and I still see it. Just by
>>> chance, I installed my normal kernel (for my other amd64 machine) onto
>>> the ISO and re-burned and it worked (since I don't have if_bge on that
>>> kernel). After selectively loading/unloading modules I tracked it down
>>> to this.
>>> Has any more traction been made on the BGE issue here?
>>> - --
>>> Coleman Kane
>> Hello, 
>> Did you run it step by step in the debugger and got the same results I
>> did? I haven't tried any more debugging ever since, but we can join our
>> forces and hopefully fix this damn issue so 7.0 won't have it on the
>> release errata. 
> I haven't gotten that far on the problem yet. Though I inspected the
> verbose booting output and saw that the point where it dies is during
> init of the bge driver.
> Which wifi card do you have? Right now this notebook has no network
> access whatsoever for me. I have tried a number of the Win64 drivers
> with ndisgen and none of them seem to work. All of the drivers that I
> can find seem to spit out some undefined function warnings on boot and
> then throw a trap 12 during ndis init.
> I've got the BCM94321 a/b/g/n card in my laptop. (product id 0x4328). I
> can't get bcmwl564.sys to detect the card, because it doesn't register
> for the 4328 chips.
You may be happy to know that I managed to find a revision of
bcmwl564.sys that works on my laptop. It is the one from Dell's website,
in the R140746.EXE package. The driver in this package does claim to
provide 802.11 a/b/g/n as well as 802.11h and d (whatever they are).

Coleman Kane

More information about the freebsd-current mailing list