ZFS does not load and mount at boot time

Gerrit Kühn gerrit at pmp.uni-hannover.de
Thu May 31 07:43:13 UTC 2007

On Thu, 31 May 2007 09:25:41 +0200 <oschonef at techfak.uni-bielefeld.de>
wrote about Re: ZFS does not load and mount at boot time:

OUBD> > When manually running "/etc/rc.d/zfs start", zfs additionally
OUBD> > complains that it may have been mounted before by a different
OUBD> > host, and I have to use -f to overcome this.
OUBD> > Are there any hints how to solve these issues?

OUBD> If you put zfs_load="YES" into loader.conf, the module will be
OUBD> loaded by the loader. If, however, the /boot/zfs/zpool.cache is not
OUBD> up-to-date or not even written (in case of a ro-mount of / in
OUBD> nanobsd) the filesystems will not be mounted automatically; they
OUBD> have to be imported manually as decribed by another post in this
OUBD> thread. I worked around that by symlinking /boot/zfs -> /etc/zfs;
OUBD> therefore zpool.cache will be saved on the /etc mfs filesystem. On
OUBD> shutdown, I save zpool.cache to nanobas's configuration slice. The
OUBD> file will then be automatically copied to /etc/zfs by rc.diskless
OUBD> and the filesystems will be mounted on boot-time.

I read the thread before and tried to circumvent problems arising from
this by setting /boot rw for testing purposes. However, without any change
in behaviour. But I'll take a look at this again anyway, thanks for the


More information about the freebsd-current mailing list