ZFS deadlocks or panics

Jan Schmidle freebsd-current at jschmidle.org
Tue Jun 26 13:52:16 UTC 2007


I'm trying to bild a storagebox with ZFS. Now I have some problems
which seems to be related to ZFS. Perhaps after adding disks to an
existing pool, all consoles trying to execute a command with I/O
operations freezes. Only sometimes I get a panic.

I played around with the tuning variables, proposed in
http://wiki.freebsd.org/ZFSTuningGuide
but didn't help.

The box is running -CURRENT amd64/SMP in a GENERIC configuration.
Last cvsup and build was "Fri Jun 22"

I also tried with i386 with and without SMP.

I collected some Information and uploaded it to
https://jschmidle.org/upload/

In "panic1" you can see a whole system-bootup resulting in a Panic.
"panic2" is just another lockup during bootup.
"areca" contains the information about the raid controller in use.
in "dump", I tried to create a coredump during a lockup.
"alltrace", "witness", "ps" also have been created during the lockup.
"sysctl" contains the current settings.

Can anyone recognize where the problem is coming from or is
additional information needed?

Jan


More information about the freebsd-current mailing list