Issues with 'xl0' keeping link

Steve Kargl sgk at troutmask.apl.washington.edu
Tue Jun 26 02:24:48 UTC 2007


On Mon, Jun 25, 2007 at 06:19:41PM -0700, Kevin Gerry wrote:
> I've noticed that after a recent patch, that xl0 is having issues syncing
> (Example from log/messages below) and wasn't sure how to 'debug' the
> interface to find out what either physically or if the driver is causing it.
> (I have attempted replacing the card with the same model)
> 
> /var/log/messages:
> Jun 25 18:10:20 storage kernel: xl0: link state changed to DOWN
> Jun 25 18:10:22 storage kernel: xl0: link state changed to UP
> Jun 25 18:11:30 storage kernel: xl0: link state changed to DOWN
> Jun 25 18:11:31 storage kernel: xl0: link state changed to UP
> Jun 25 18:12:15 storage kernel: xl0: link state changed to DOWN
> Jun 25 18:12:17 storage kernel: xl0: link state changed to UP
> Jun 25 18:12:38 storage kernel: xl0: link state changed to DOWN
> Jun 25 18:12:39 storage kernel: xl0: link state changed to UP
> 

Good luck in getting any help.  bge0 has been going DOWN/UP for
about 2 months.  I've managed to get around the problem by adding

net.inet.tcp.sendspace=131072
net.inet.tcp.recvspace=131072
net.inet.tcp.path_mtu_discovery=0
net.inet.udp.recvspace=65536
net.inet.raw.recvspace=16384
hw.pci.enable_msix=0
hw.pci.enable_msi=0
kern.ipc.nmbclusters=50000
kern.timecounter.hardware=ACPI-fast

to /etc/sysctl.conf.

I also adjusted a few hardcoded parameters in if_bge.c and if_bgereg.h.

-- 
Steve


More information about the freebsd-current mailing list