panic when removing pccard

Hans Petter Selasky hselasky at c2i.net
Tue Jun 19 11:31:56 UTC 2007


On Tuesday 19 June 2007 13:25, Niki Denev wrote:
> Hans Petter Selasky wrote:
> > On Tuesday 19 June 2007 11:06, Niki Denev wrote:
> >> Hans Petter Selasky wrote:
> >>> On Friday 08 June 2007 10:31, Niki Denev wrote:
> >>>> -----BEGIN PGP SIGNED MESSAGE-----
> >>>> Hash: SHA1
> >>>>
> >>>> I experience the following panic on a few days old -current :
> >>>>
> >>>> If i insert and then remove a pcmcia card using the ubsa module
> >>>> (Vodafone Mobile Connect, which actually is Huawei E630 UMTS/HSDPA
> >>>> modem) the machine panics, because i think the order of removal of the
> >>>> devices by the kernel is not correct. I'm not sure because i don't
> >>>> have -STABLE machine with pcmcia now, but i think this problem does
> >>>> not exist there.
> >>>>
> >>>> Here is what happens when card is inserted :
> >>>
> >>> Hi!
> >>>
> >>> If you want to be able to remove the card you need to install the new
> >>> USB stack. The old USB stack is completely broken when it comes to this
> >>> point!
> >>>
> >>> --HPS
> >>>
> >>> http://www.turbocat.net/~hselasky/usb4bsd
> >>>
> >>> Install the SVN version.
> >>> _______________________________________________
> >>
> >> I've followed the instructions and did a svn checkout of the source,
> >> then did make install and after this i rebuilt my kernel and modules (i
> >> had to disable if_ural)
> >> But even after this i get the same panic when removing this specific
> >> card.
> >>
> >> P.S.: How can i be sure that my new kernel and modules are using the new
> >> USB stack?
> >> I'm thinking that maybe something got wrong with the installation.
> >
> > Check the "dmesg".
> >
> > If you see something like:
> >
> > usb0: 12MBps Full Speed USB v1.0
> > usb1: 12MBps Full Speed USB v1.0
> > usb2: 12MBps Full Speed USB v1.0
> > usb3: 480MBps High Speed USB v2.0
> >
> > Then you are using the new stack.
> >
> > Make sure that you are using the latest version. Hence you needed to
> > remove "if_ural.c" it does not sound like you are using the latest
> > version.
> >
> > Do a "svn update" again, build a new package, install that, and build a
> > new kernel.
> >
> > --HPS
>
> I csuped a fresh -current source, then did a frech svn checkout of the
> new usb stack
> make package and make install went ok, then i proceeded to build the
> kernel, but it failed and complained about missing usbdevs.h
> i regenerated the file using the awk script in sys/tools and
> sys/dev/usb/usbdevs as source file,
> but then the build failed again with (these messages were also present
> in the first build failure):

Did you execute "make S=../src package" ? Or just "make package" ?

--HPS


More information about the freebsd-current mailing list