LOR in iwi with new 802.11 work

Stefan Ehmann shoesoft at gmx.net
Fri Jun 15 13:12:22 UTC 2007


On Friday 15 June 2007 12:39:48 Andrew Thompson wrote:
> On Fri, Jun 15, 2007 at 10:44:31AM +0200, Stefan Ehmann wrote:
> > On Thursday 14 June 2007 18:16:54 Sam Leffler wrote:
> > > Stefan Ehmann wrote:
> > > > After the system is up for about 5 minutes, I see this LOR. Haven't
> > > > seen it posted yet.
> > > >
> > > > Stefan
> > > >
> > > > lock order reversal:
> > > >  1st 0xc2e4700c ieee80211com (802.11 com lock)
> > > > @ /usr/src/sys/net80211/ieee80211_scan.c:523
> > > >  2nd 0xc2e48400 iwi0 (network driver)
> > > > @ /usr/src/sys/modules/iwi/../../dev/iwi/if_iwi.c:1908
> >
> > ...
> >
> > > Yes, known and can safely be ignored.
> >
> > Okay, thanks.
> >
> > Another problem I've noticed (don't want to start a new thread):
> >
> > Before the latest commit, I've never seen dropouts in the connnection.
> >
> > But now I've seen for the second time that the connection drops for some
> > seconds. ifconfig shows no IP address. At least it recovers, but open
> > connections die.
> >
> > In dmesg I see:
> >
> > Jun 15 10:34:25 something kernel: iwi0: firmware stuck in state 4,
> > resetting Jun 15 10:34:25 something kernel: iwi0: link state changed to
> > DOWN Jun 15 10:34:28 something kernel: iwi0: link state changed to UP
> >
> > Is this a known issue? Do you need any more info?
>
> It appears to get stuck in background scanning. How often does it
> happen? If you could set debug.iwi=3 and then email the logs for a
> couple of iterations of the reset.

Seems to happen every few scanning iterations though sometimes it works.
$ grep stuck /var/log/messages
Jun 15 11:24:20 something kernel: iwi0: firmware stuck in state 4, resetting
Jun 15 11:46:05 something kernel: iwi0: firmware stuck in state 4, resetting
Jun 15 12:02:58 something kernel: iwi0: firmware stuck in state 4, resetting
Jun 15 12:19:21 something kernel: iwi0: firmware stuck in state 4, resetting
Jun 15 12:47:10 something kernel: iwi0: firmware stuck in state 4, resetting
Jun 15 13:03:32 something kernel: iwi0: firmware stuck in state 4, resetting

messages with debug.iwi=3 as requested
http://stud4.tuwien.ac.at/~e0125637/fbsd/messages_iwi

Stefan


More information about the freebsd-current mailing list