Samba access to ZFS broken

Timur I. Bakeyev timur at
Wed Jun 13 03:09:21 UTC 2007

Hi, Stefan and Johan!

On Fri, Jun 01, 2007 at 03:25:24PM +0200, Stefan Esser wrote:
> Johan Hendriks wrote:
> >> On 2007-05-31 14:18 +0200, Johan Hendriks <Johan at> wrote:
> > 
> Well, what finally saved me after hours of effort spent trying to get
> samba to work was your mail, which described exactly the symptoms my
> system showed. When I read that it was specific to ZFS, I tried with
> an MFS exported via samba, which just worked ... I had spent hours
> recompiling all dependencies and looking at a possible config file
> error. So, thank you for reporting it and for mentioning ZFS ;-)

So, did you succed with MDMFS or it was other sort of MD mounted node?
There are reports, that at least for ISO9660 mounted via MD Samba doesn't
work either. As well as with FAT32 partitions. The simphoms are the same,
abort() somewhere in the directory traversing code(SIG 6).

> But the local-NFS work-around keeps my system working despite the
> current samba/ZFS incompatibility. (I can't easily move the data
> to UFS and need to provide CIFS access to a large spool area for
> an appliance that supports just that protocol ...)

Can you, please, provide more detailed logging with:

log level = 10
log file = /var/log/samba/log.%m.%S

Or smth. alike, so access to the share will be logged into the separate

Also, backtrace of the coredump could be helpful. Please, send the
results either to me or submit them into, so they can
be traced down.

With best regards,
Timur Bakeyev.

More information about the freebsd-current mailing list