Samba access to ZFS broken

Stefan Esser se at
Fri Jun 1 13:41:20 UTC 2007

Johan Hendriks wrote:
> -----Oorspronkelijk bericht-----
> Van: Stefan Eßer [mailto:se at] 
> Verzonden: donderdag 31 mei 2007 23:46
> Aan: Johan Hendriks
> CC: freebsd-current at
> Onderwerp: Samba access to ZFS broken
>> On 2007-05-31 14:18 +0200, Johan Hendriks <Johan at> wrote:
>> I don't think so, since I'm observing the same problem on a 
>> single-CPU system with different configuration. Common is 
>> Samba access to files stored on ZFS.
>> My current work around is to NFS export the file systems and to 
>> mount them on localhost. Samba works just fine when configured
>> to access files in ZFS via this NFS loopback. (It does not work
>> on a nullfs mount of the ZFS partitions.)
>> I have no time for further tests before the weekend, but this 
>> seems to either be a bug introduced by a recent ZFS change, or
>> to be caused by compilation with gcc-4.2.
>> Regards, Stefan
> Ok nice to hear it is not me.

Well, what finally saved me after hours of effort spent trying to get
samba to work was your mail, which described exactly the symptoms my
system showed. When I read that it was specific to ZFS, I tried with
an MFS exported via samba, which just worked ... I had spent hours
recompiling all dependencies and looking at a possible config file
error. So, thank you for reporting it and for mentioning ZFS ;-)

> It used to work, and if I recall it did not work with version 3.0.24 also after the gcc update.

Ok, I've got a small file server running -current (because I wanted
to give ZFS a try) and I needed to reboot to disable ZFS read-ahead
(which appears to be a pessimisation at least on small servers; I
think vfs.zfs.prefetch_disable="1" should be the default, it seems
to not be adaptive as in our UFS, where read-ahead is gradually
increased if a file is really sequentially read).

> But I did not have time to go look for the problem at that moment.

I plan to test the previous kernel (from early may) with the current
samba (and if that does not work, the previous samba with the new

But the local-NFS work-around keeps my system working despite the
current samba/ZFS incompatibility. (I can't easily move the data
to UFS and need to provide CIFS access to a large spool area for
an appliance that supports just that protocol ...)

Regards, STefan

More information about the freebsd-current mailing list