ZFS does not load and mount at boot time

Gerrit Kühn gerrit at pmp.uni-hannover.de
Mon Jun 4 15:59:54 UTC 2007

On Mon, 4 Jun 2007 17:27:03 +0200 Gerrit Kühn <gerrit at pmp.uni-hannover.de>
wrote about Re: ZFS does not load and mount at boot time:

GK> I have now moved zfs.cache to /etc/zfs and load the module via
GK> rc.conf. I have also included the saving of zfs.cache on /cfg in "zfs
GK> stop" and set KEYWORD: shutdown for zfs. However, I still get 
GK> ZFS: WARNING: pool 'tank' could not be loaded as it was last accessed
GK> by another system (host: eclipse.aei.uni-hannover.de hostid:
GK> 0xf7ab4bd6). See: http://www.sun.com/msg/ZFS-8000-EY
GK> when booting. Any further ideas?

Strange... neither "/etc/rc.shutdown.local" nor "/etc/rc.d/zfs stop" seems
to be run when rebooting. But when running zfs stop manually before
rebooting, the system comes back with the same error when trying to mount
zfs volumes, so there are probably at least two problems left to solve


More information about the freebsd-current mailing list