Issues with kernel / userland drivers after recent install and upgrade

youshi10 at u.washington.edu youshi10 at u.washington.edu
Fri Jun 1 19:54:43 UTC 2007


Hello,

      I have the following issues with a clean install of 7-CURRENT; they may be related to the GCC upgrade or other things.

Background:
      I started out with a virgin clean 6.2-RELEASE system, then went straight to 7-CURRENT (synced yesterday) without installing anything (to avoid having to reinstall packages, etc).

pass:
1. I have pass compiled into the kernel statically, but /dev/pass* isn't created on boot (devfs is running properly I believe).

ohci/ukbd/ums:
1. These aren't operating properly. I can't see any keyboard output even though before when I didn't compile ukbd into the kernel the USB keyboard worked magically with slight lag preceding the first input.
2. The mouse cursor doesn't move whatsoever.
3. OHCI isn't detected on boot, and I think that only UHCI is detected properly, even though my board is EHCI/OHCI capable (Asus P5B-Deluxe).

GEOM:
1. I have GEOM compiled into the kernel because I'm using AHCI and the Intel RAID (iir) driver, but there's an issue where if I pop in a CD and it attempts to read it or write to it, it will always fail with READ_BIG errors. This didn't happen in 6.2-RELEASE.

I will try upgrading my BIOS soon (haven't installed Windows yet / don't have a USB key so I haven't tried doing this yet), and hopefully the problems will all go away. However, I'm not sure if they will, so if anyone has any ideas for why things are occurring and has some solutions to explore or tests to try, I would be more than happy to get anyone's input.

Thanks,
-Garrett



More information about the freebsd-current mailing list