GVirstor Label problem on -CURRENT

Ivan Voras ivoras at fer.hr
Thu Apr 26 16:25:01 UTC 2007

Jason Hills wrote:

> So I tried to make a smaller virtual storage, 40G:
> # ./gvirstor label -v -s 400000 mystor ad3s1d
> Resizing virtual size to fit virstor structures
> New virtual size: 400128 MB (32 new chunks)
> Total virtual chunks: 100032 (4 MB each), 400128 MB total virtual size.
> Clearing metadata on ad3s1d.
> Writing allocation table to ad3s1d... (0 MB, 1 chunks)
> Tried to write 800256, written 4294967295 (Operation not permitted)
> Error writing out allocation map!

Can you verify that dd works on that partition? For example, use

# dd if=/dev/zero of=/dev/ad3s1d bs=512 count=1563

And tell me if this works or fails.


-------------- next part --------------
A non-text attachment was scrubbed...
Name: signature.asc
Type: application/pgp-signature
Size: 250 bytes
Desc: OpenPGP digital signature
Url : http://lists.freebsd.org/pipermail/freebsd-current/attachments/20070426/7bc37f67/signature.pgp

More information about the freebsd-current mailing list