GVirstor Label problem on -CURRENT

Jason Hills jazzhills at gmail.com
Thu Apr 26 15:53:26 UTC 2007

> A possible reason could be that the virstor map is larger than your
> physical storage (I think I don't have a check for this in the code
> [yet]). How large is ad3s1d?

Around 36G

# disklabel ad3s1
# /dev/ad3s1:
8 partitions:
#        size   offset    fstype   [fsize bsize bps/cpg]
  c: 78156162        0    4.2BSD     2048 16384 28552   # "raw" part, don't edit
  d: 78156162        0    4.2BSD     2048 16384 28552

So I tried to make a smaller virtual storage, 40G:

# ./gvirstor label -v -s 400000 mystor ad3s1d
Resizing virtual size to fit virstor structures
New virtual size: 400128 MB (32 new chunks)
Total virtual chunks: 100032 (4 MB each), 400128 MB total virtual size.
Clearing metadata on ad3s1d.
Writing allocation table to ad3s1d... (0 MB, 1 chunks)
Tried to write 800256, written 4294967295 (Operation not permitted)
Error writing out allocation map!

same thing

Jazzie Hills

More information about the freebsd-current mailing list