recent CURRENT seems to affect if_tap, if_bridge with qemu

Scott Robbins scottro at
Tue Apr 10 01:04:04 UTC 2007

On Mon, Apr 09, 2007 at 09:27:18AM -0400, Scott Robbins wrote:

> I have been using qemu and qemu-devel with if_tap and if_bridge.  
> The home network is a, I give the bridge a 192.168.1.x/32
> address add tap0 and vr0 (the host machine's interface) as members, and
> give the qemu guest a 192.168.1.x/24 address with the same gateway as
> the host.  This has worked perfectly through March.  The host runs
> CURRENT.  I didn't upgrade it through most of March, then finally had
> time to do a buildworld the first week of April.  

To follow up, the problem seems to be solved.  In private email, someone
suggested to me that I ensure that both bridge0 and tap0 were up.  Prior
to my latest update of CURRENT, my /etc/qemu-ifup script just had 

/sbin/ifconfig ${1}

Changing it to 

/sbin/ifconfig ${1} up

fixed the problem. 


Scott Robbins

GPG KeyID EB3467D6
( 1B848 077D 66F6 9DB0 FDC2  A409 FA54 D575 EB34 67D6)
gpg --keyserver --recv-keys EB3467D6

Xander: What's going on here? People are going all Felicity with 
their hair. 

More information about the freebsd-current mailing list