recent CURRENT seems to affect if_tap, if_bridge with qemu

Scott Robbins scottro at
Mon Apr 9 13:51:30 UTC 2007

I have been using qemu and qemu-devel with if_tap and if_bridge.  
The home network is a, I give the bridge a 192.168.1.x/32
address add tap0 and vr0 (the host machine's interface) as members, and
give the qemu guest a 192.168.1.x/24 address with the same gateway as
the host.  This has worked perfectly through March.  The host runs
CURRENT.  I didn't upgrade it through most of March, then finally had
time to do a buildworld the first week of April.  

The bridged networking stopped working.  The guest can only ping its
own interface.   Running tcpdump briefly indicated that nothing was
reaching bridge0 or tap0 from the guest.  

Trying to figure out if it's a CURRENT issue or qemu issue, I threw a
March snapshot of CURRENT on a second box, then qemu.  I set it up as I
usually do with bridging and it worked.  I then ran buildworld and had
the same result--the guest could no longer reach the outside world. 

I'm not sure what other information would help.  I lack the time and
expertise to try various dates of CURRENT and see exactly when this

Thank you for any pointers. 


Scott Robbins

GPG KeyID EB3467D6
( 1B848 077D 66F6 9DB0 FDC2  A409 FA54 D575 EB34 67D6)
gpg --keyserver --recv-keys EB3467D6

Buffy: Do---do you think I chose to be like this? Do you have any
idea how lonely it is, how dangerous? I would love to be upstairs
watching TV or gossiping about boys or... God, even studying! But
I have to save the world. Again. 

More information about the freebsd-current mailing list