linux-flashplugin-6.0 not working anymore

Eric Anderson anderson at
Thu Jan 5 13:39:52 PST 2006

Nicolas Blais wrote:

>A while ago I noticed that firefox and konqueror are not displaying flash 
>applets anymore on my -CURRENT system yet it works fine on all my 6-STABLE 
>When I run firefox from the shell, I get:
>[nicblais at clk01a] ~> firefox
>LoadPlugin: failed to initialize shared 
>library /usr/X11R6/lib/linux-flashplugin6/ 
>[/usr/local/lib/pluginwrapper/ version GLIBC_2.1 required 
>by /usr/X11R6/lib/linux-flashplugin6/ not defined]
>(I have linux-glib2-2.4.8_1 installed)
>My libmap.conf is untouched : 
># Flash6 with Mozilla/Firebird/Galeon/Epiphany/Konqueror/Kazehakase
>                 pluginwrapper/
>                      pluginwrapper/
>                       pluginwrapper/
>And konqueror no longer finds my linux-flashplugin-6.0. The mplayer plugin is 
>detected fine in both browsers. Since the linuxpluginwrapper port is broken 
>for -CURRENT, I haven't tried to mess with it.
>Am I the only one with this problem?

No - I too have this problem, and can't find a solution.  It broke with 
some commits back around Dec 20th, 2005 from Alexander Kabaev I think.   
I mentioned it, and his response was something like:

The segfault was caused by *((char *)0) = 0; statement that I forgot to
remove from the source before committing. Now firefox does not segfault
but properly fails to load plugin due to inadequate versioning
emulation by flash[67].so wrappers.

See the thread with a subject of:
[openoffice]no suitable windowing system found, exiting.


Eric Anderson        Sr. Systems Administrator        Centaur Technology
Anything that works is better than anything that doesn't.

More information about the freebsd-current mailing list