Linux compat oddness

ttw ttw at
Thu Sep 22 10:49:25 PDT 2005

On 22.09-22:39, Daniel O'Connor wrote:
[ ... ]
> I'm trying to get the Xilinx Webpack tools running under FreeBSD..
> I downloaded a bunch of RH Enterprise RPMs for the libraries it needs (
> for the installer anyway) but I am stuck now with..
> [inchoate 22:21] /tmp/Xilinx >/compat/linux/bin/env LD_LIBRARY_PATH=/tmp/Xilinx/lib:/tmp/Xilinx/usr/X11R6/lib:/tmp/Xilinx/usr/lib:/tmp/Xilinx/platform/lin/bin/lin /tmp/Xilinx/platform/lin/xilsetup
> /tmp/Xilinx/platform/lin/xilsetup: error while loading shared libraries: /usr/lib/ ELF file OS ABI invalid
> Which isn't suprising since is a FreeBSD binary..
> I've branded the xilsetup binary, and even tried setting the fallback branding
> to 3 but it gives the same result.

my general solution to these problems is to ensure i have devfs
mounted in /compat/linux/dev and chroot to /compat/linux.

eliminates any freebsd "interference" and avoids nasty blasting of
bsd libraries and such.

my guess as to your problem is that the installer is searching for
the libraries manually instead of asking the kernel.

More information about the freebsd-current mailing list